Merge branch '2015.11-develop' into 2016.03
[tine20] / tine20 / composer.json
1 {
2     "name": "tine20/server",
3     "description": "Tine 2.0 Server",
4     "type": "project",
5     "keywords": ["Groupware", "Collaboration", "CRM", "Calendar", "Addressbook", "Teamwork", "Tasks", "Timetracking"],
6     "homepage": "http://www.tine20.org",
7     "license" : ["AGPL-3.0", "BSD-3-Clause", "LGPL-2.1+", "MIT"],
8     "repositories": [{
9       "type": "git",
10       "url": "http://git.tine20.org/git/composerapploader"
11     }, {
12         "type": "git",
13         "url": "http://git.tine20.org/git/zendframework1"
14     },{
15         "type": "git",
16         "url": "http://git.tine20.org/git/opendocument"
17     }, {
18         "type": "git",
19         "url": "http://git.tine20.org/git/timezoneconvert"
20     }, {
21         "type": "git",
22         "url": "http://git.syncroton.org/Syncroton"
23     }],
24     "require": {
25         "zendframework/zendframework1": "1.12.18",
26         "tine20/composerapploader": "dev-master",
27         "syncroton/syncroton": "1.1.*",
28         "ezyang/htmlpurifier": "v4.6.0",
29         "codeplex/phpexcel": "1.7.8",
30         "phpoffice/phpword": "0.12.*",
31         "sabre/dav": "1.8.*",
32         "sabre/vobject": "3.1.3 as 2.1.313",
33         "metaways/opendocument": "1.1",
34         "metaways/timezoneconvert": "0.2",
35         "zendframework/zend-http": "2.4.*",
36         "doctrine/orm": "2.5.*"
37     },
38     "require-dev": {
39         "phpunit/phpunit": "3.7.*",
40         "phing/phing": "2.*"
41     },
42     "autoload": {
43         "files": [],
44         "psr-0": {
45             "": ["", "library"],
46             "TimeZoneConvert": "library/TimeZoneConvert/lib/",
47             "Zend_": ["vendor/zendframework/zendframework1/library"],
48             "qCal": "library/qCal/lib"
49         },
50         "classmap": [
51             "library/idnaconvert"
52         ]
53     },
54     "include-path-desc": "ZF1 still needs include path as it does not consequently use autoloading internally",
55     "include-path": ["", "vendor/zendframework/zendframework1/library", "library"],
56     "config": {
57         "secure-http": false
58     }
59 }